• 18976542384

    工作时间

    周一至周五:9:00-21:00

    周末及节日:9:00-18:00

  • 手机版二维码

    手机快速找资源

  • 扫描二维码

    加入官方qq群

[源码] 精准顶底买卖主图指标

15
回复
2849
查看
[复制链接]

1

主题

3

回帖

19

积分

新手上路

Rank: 1

积分
19
发表于 2021-12-29 14:00:30 | 显示全部楼层 |阅读模式
AA:=BARSCOUNT(C);

AH:=HHV(H,200);

AL:=LLV(L,200);

A0:=(AH-AL)/40;

B1:=L-A0;

MA5:MA(C,5);

MA6:=MA(C,6);

MA10:MA(C,10);

MA20:MA(C,20);

MME:=MA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(LOW,34)),5)-20;

MM12:=(H+LOW+C)/3;

MM13:=(MM12-MA(MM12,14))/(0.015*AVEDEV(MM12,14));

MM14:=(MM12-MA(MM12,70))/(0.015*AVEDEV(MM12,70));

MM15:=IF(MM13>=150 AND MM13<200 and="" MM14="">=150 AND MM14<200,10,0);

MM16:=IF(MM13<=-150 and="" MM13="">-200 AND MM14<=-150 and="" MM14="">-200,-10,MM15);

MM17:=(C-MA(C,13))/MA(C,13)*100;

MM18:=100-ABS(MM17);

MM19:=IF(MM18<90,MM18,100);

A2:=REF(MA20,1);

STICKLINE((AA+0)/34=FLOOR((AA+0)/34),B1,B1-1.5*A0,2,0),COLORF00FF0;

DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),B1-1*A0,'要变盘'),COLORF00FF0;

MM2S:=(2*C+H+LOW)/4;

MM3S:=IF(YEAR>=2099 AND MONTH>2,0,1);

MM4S:=LLV(LOW,5); MM5S:=HHV(H,4);

J1:=(MA20-A2)/A2*100;

MJ1:=MA(J1,3);

MA30:MA(C,30);

MA60:MA(C,60);

MA120:MA(C,120);

MM1A:=IF(MME>0,MME,0);

MM1B:=IF(MM14>=200 AND MM13>=150,15,IF(MM14<=-200 AND MM13<=-150,-15,MM16))+60;

MM1C:=MM1A>48 AND MM1B>60 AND MM19<100;

乖离2:=(MA20-MA30)/MA30*100;

MM1:=IF(BETWEEN(乖离2,-2,5),2,0);

散户:=EMA((MM2S-MM4S)/(MM5S-MM4S)*100,4)*MM3S;

庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*MM3S;

DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,''),COLORRED;

MAX1:=MAX(MA20,MA30);

MAX2:=MAX(MAX1,MA60);

MIN9:=MIN(MA20,MA30);

MIN2:=MIN(MIN9,MA60);

K1:=(MAX2/MIN2-1)*100;

MM2:=IF(K1<=8,1,0);

BBB1:=MA(C,1);

B2:=SMA(SMA(SMA(BBB1,2,1),2,1),2,1),COLORRED;

SMA2:=MA(B2,2);

MMB1:=(100 - ((90 * (HHV(H,21) - C)) / (HHV(H,21) - LLV(LOW,21))));

MM3:=(100 - MA(((100 * (HHV(H,6) - C)) / (HHV(H,6) - LLV(LOW,6))),34));

买:DRAWTEXT(CROSS(MMB1,MM3) AND B2>SMA2,(LOW * 0.97),'←绝买点'),COLORRED;

上火车轨:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND MA20-MA30>REF((MA20-MA30),1) ;

STICKLINE(上火车轨,MA20,MA30,0,0),COLORRED;

神枪手:=DRAWTEXT(FILTER(上火车轨 AND "MACD.DIF"<0.15 and="">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND

( L<=ma20 and="" c="">MA20 OR (CROSS(MA5,MA20)) ),5),L*0.98,'←神枪手');

神枪手选股:=FILTER(上火车轨 AND "MACD.DIF"<0.15 and="">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND

( L<=ma20 and="" c="">MA20 OR (CROSS(MA5,MA20)) ),5);

短线暴涨:DRAWTEXT(FILTER( (MM1 OR MM2) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)

AND MA(V,60)>REF(MA(V,60),1),5),MA60*0.99,'短线暴涨'),COLORRED;

DRAWTEXT(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30 and="" j1="">MJ1 AND MA60>REF(MA60,1) AND COUNT(J1<1,3)>=1 ,L*0.995,'←买入'),COLORYELLOW;

DRAWTEXT(CROSS("KDJ.D"(5,2,3),"KDJ.K"(5,2,3)) AND "KDJ.D"(5,2,3)>65 AND J1>=1,H*1.005,'←卖出'),COLORGREEN;

DRAWTEXT(CROSS("KDJ.D"(18,9,6),"KDJ.K"(18,9,6)) AND "KDJ.D"(18,9,6)>60 AND "KDJ.J"(45,15,15)>90,H*1.03,'←顶'),COLORRED;

DRAWTEXT(CROSS(MA5,MA6) AND "KDJ.K"(5,3,3)>=50 AND "KDJ.J"(5,3,3)<31 ,L*0.92,'←再买'),COLORMAGENTA;

XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((C / REF(C,1)) >= 1.04));

XL2:=(((C - EMA(C,21)) / EMA(C,21)) * 100);

XL3:=CROSS(XL2,(0 - 20));

DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),'●买点');

DRAWTEXT((XL3 > 0),(LOW - 0.2),'●绝对底部');

X6:=REF(C,1);

X7:=((SMA(MAX((C - X6),0),7,1) / SMA(ABS((C - X6)),7,1)) * 100);

X8:=CROSS(79,X7);

X9:=FILTER(X8,4);

DRAWTEXT(X9,(H * 1.02),'●出货'),COLOR9000F5;

STICKLINE(C>1.098*REF(C,1),C,O,0,0),COLORYELLOW;

DRAWTEXT(MM1C AND COUNT(MM1C,30)=1,H*1.02,'大笔出货'),LINETHICK1,COLORFFCC66;

AA1:=AMOUNT/V;

BB1:=L; CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;

DD1:=L; EE1:=V; AAA:=CONST(HHV(H,90));

R1:=MA(C,1);

R2:=MA(C,3);

R3:=(MA(R2,1)*1);

R4:=(MA(R2,3)*1);

DRAWTEXT(CROSS(R3,R4),(LOW-0.1),''),COLORYELLOW;

LC:=REF(C,1);

RSI:=((SMA(MAX((C - LC),0),3,1) / SMA(ABS((C - LC)),3,1)) * 100);

W:=(C-LLV(LOW,4))/(HHV(H,4)-LLV(LOW,4))*100;

FF:=EMA(C,3);

MA15:=EMA(C,21);

DRAWTEXT(CROSS(88,RSI),(H * 1.02),'出'),COLORGREEN;

很多人认为,股票学个三五个月或者一两年总是能学会。其实学习是一辈子的事情,绝对不是一段时间。从股票知识的角度来而言,学个两三年就差不多了但是如果你要是一边实践,一边学习,一边感悟,深刻理解知识,并不是那么容易。

所谓纸上得来终觉浅,绝知此事要躬行。


回复

使用道具 举报

0

主题

6

回帖

23

积分

新手上路

Rank: 1

积分
23
发表于 2021-12-29 15:05:01 | 显示全部楼层
帮顶!
回复

使用道具 举报

0

主题

10

回帖

31

积分

新手上路

Rank: 1

积分
31
发表于 2021-12-31 03:49:34 | 显示全部楼层
爱分享,爱生活
回复

使用道具 举报

2

主题

10

回帖

43

积分

新手上路

Rank: 1

积分
43
发表于 2022-1-4 05:55:39 | 显示全部楼层
我都想要,怎么办?
回复

使用道具 举报

0

主题

10

回帖

30

积分

新手上路

Rank: 1

积分
30
发表于 2022-1-6 05:23:56 | 显示全部楼层
很好的内容,感谢分享!
回复

使用道具 举报

0

主题

6

回帖

24

积分

新手上路

Rank: 1

积分
24
发表于 2022-1-18 02:13:08 | 显示全部楼层
相当不错,感谢无私分享精神!
回复

使用道具 举报

0

主题

7

回帖

29

积分

新手上路

Rank: 1

积分
29
发表于 2022-2-13 11:09:08 | 显示全部楼层
路过,学习下
回复

使用道具 举报

0

主题

11

回帖

33

积分

新手上路

Rank: 1

积分
33
发表于 2022-2-17 09:46:08 | 显示全部楼层
不错的内容!
回复

使用道具 举报

0

主题

17

回帖

49

积分

新手上路

Rank: 1

积分
49
发表于 2022-2-18 13:49:20 | 显示全部楼层
好人啊!
回复

使用道具 举报

0

主题

16

回帖

45

积分

新手上路

Rank: 1

积分
45
发表于 2022-2-20 19:09:17 | 显示全部楼层
这个资源我有了,不过还是感谢楼主分享
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

全国统一客服电话
18976542384

24x7小时免费咨询

  • 官方在线客服

    QQ客服:股海浪子

    点击交谈

    QQ客服:beyond

    点击交谈

    QQ客服:明月

    点击交谈
  • 广东省深圳市福田区深南大道2012号

  • 添加客服微信

    可领取网站任一指标一个

  • 加入指标qq分享群

    免费领取资源

Powered by Discuz!X3.4 ©2001-2013 Comsenz Inc.彩虹桥投资充电站( 粤ICP备19084539号-1 )|网站地图