• 18976542384

    工作时间

    周一至周五:9:00-21:00

    周末及节日:9:00-18:00

  • 手机版二维码

    手机快速找资源

  • 扫描二维码

    加入官方qq群

[源码] 通达信指标公式源码黄金分割指标

8
回复
2038
查看
[复制链接]

1

主题

15

回帖

46

积分

新手上路

Rank: 1

积分
46
发表于 2023-4-23 21:45:24 | 显示全部楼层 |阅读模式

彩虹桥-投资充电站

AA05:MA(C,5),COLORFFFFFF;

五日乖离率:=(C-AA05)/AA05*100;

BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;

速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);

加速度5:EMA((速度5-REF(速度5,1)),3),NODRAW;

{IF(BB05>30 AND AA05>REF(AA05,1), AA05,DRAWNULL),LINETHICK3,COLORRED;}

AA10:MA(C,10);AA20:=MA(C,20);

BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;

{IF(BB05<0 AND AA05
AA30:MA(C,30);

三拾日乖离率:(C-AA30)/AA30*100,NODRAW;

VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);

VAR2:=(AA30-AA20)
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;

{IF(BB30>15 AND AA30>REF(AA30,1), AA30,DRAWNULL),LINETHICK3,COLORFF00FF;}

强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);

加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)

AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;

清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05
DRAWTEXT(加仓 ,LOW*0.98,'←加仓'),COLORRED;

JC:=CROSS(0,五日乖离率) AND 三拾日乖离率REF(AA10,1) ;

减仓:=FILTER(JC,10);

MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)
买入:=FILTER(MR,10);

DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORCYAN;

DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;

DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;

DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;

VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));

VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);

MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;

支撑价:LLV(LOW,19),LINETHICK3 , COLOR00FF00;

阻力价:HHV(HIGH,19),COLORBLUE, LINETHICK3;

VARB1:=EMA(CLOSE,12)-EMA(CLOSE,26);

VARB2:=EMA(VARB1,9);

VARB3:=(CLOSE*2.5/100+CLOSE);

VAR4:EMA(C,3), LINETHICK3,COLORRED;

VAR5:=LLV(HIGH,240);

VAR6:=100*(CLOSE-VAR5)/VAR5;

VAR7:=REF(LLV(CLOSE,480),1);

VAR8:=REF(HHV(CLOSE,480),1);

VAR9:=100*(CLOSE-VAR7)/(VAR8-VAR7);

VARA:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100;

VARB:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100;

VARC:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100;

VARD:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100;

VARE:=VARC>98.5 OR VARD>98.5;

VARF:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5)/4;

VAR13:=VARA=0 AND VARC=0 AND VAR6<0;

VAR14:=VARA=100 AND VARC=100;

VAR15:=VARB=0 OR VARD=0 AND VAR9<0;

VAR16:=VARB=100 AND VARD=100;

VAR17:=VAR6<0 AND VAR9<0;

VAR18:=VAR13 AND VAR15;

VAR19:=VAR14 AND VAR16;

VAR1B:=SMA(MAX(CLOSE-REF(CLOSE,1),0),49,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;

VAR1C:=SMA(MAX(CLOSE-REF(CLOSE,1),0),14,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),14,1)*100;

VAR1D:=BARSCOUNT(CLOSE);

VAR1E:=VAR1B<20 AND VAR1C<23 AND VAR1D>35;

VAR1F:=VAR1E AND COUNT(VAR1E,1)=1;

VAR20:=REF(CLOSE,1);

VARB21:=SMA(MAX(CLOSE-VAR20,0),34,1)/SMA(ABS(CLOSE-VAR20),7,1)*100;

VAR22:=SMA(MAX(CLOSE-VAR20,0),13,1)/SMA(ABS(CLOSE-VAR20),13,1)*100;

VAR23:=BARSCOUNT(CLOSE);

VAR24:=VARB21<20 AND VAR22<23 AND VAR23>35;

VAR25:=VARA=0 AND VARF<1.2 AND VAR17;

VAR27:=VAR18 AND VARF<1.2 AND VAR17;

VAR29:=SUM(HIGH-OPEN,77)/SUM(OPEN-LOW,77)*100;

VAR2A:=SUM(MAX(0,HIGH-REF(CLOSE,1)),77)/SUM(MAX(0,REF(CLOSE,1)-LOW),77)*100;

VAR2B:=CROSS(VAR29,69) AND CROSS(VAR2A,80)<150;

VAR2C:=VAR24 AND VAR1F AND COUNT(VAR24,30)=1;

买点:=VAR25 AND VAR2B;

绝对卖点:=(VAR19 OR VARA)AND VARF>23 OR VARE ;

VAR2D:=VAR1F AND VAR2C AND VAR25;

股海万元户:=(CLOSE/REF(CLOSE,1)>1.04 AND (CLOSE>10.8 AND CLOSE<10.83 OR CLOSE>6.86 AND CLOSE<6.88 OR CLOSE>13.82 AND CLOSE<13.84 OR CLOSE>7.28 AND CLOSE<7.3 OR CLOSE>12.4 AND CLOSE<12.42 OR CLOSE>22.33 AND CLOSE<22.35 OR CLOSE>4.68 AND CLOSE<4.7 OR CLOSE>26.29 AND CLOSE<26.31 OR CLOSE>7.65 AND CLOSE<7.67 OR CLOSE>13.4 AND CLOSE<13.42 OR CLOSE>7.58 AND CLOSE<7.6 OR CLOSE>20.43 AND CLOSE<20.45 OR CLOSE>19.57 AND CLOSE<19.59 OR CLOSE>6.26 AND CLOSE<6.28 OR CLOSE>7.14 AND CLOSE<7.16 OR CLOSE>6.61 AND CLOSE<6.63 OR CLOSE>11.9 AND VOL<11.92 OR CLOSE>6.7 AND CLOSE<6.72 OR CLOSE>8.19 AND CLOSE<8.21));

DRAWTEXT(FILTER(绝对卖点>0,3),H,'别贪'), COLOR00FF00;

DRAWTEXT(股海万元户>0,L,'☆追涨'),COLORYELLOW ;

DRAWICON(买点>0,L,4);

DRAWTEXT(买点>0,L,'扫描神针'),COLORF00FF0;

DRAWTEXT(VARF<0.7 AND VAR27 AND VAR25>0,L,'万元'),COLORYELLOW;

STICKLINE(VAR2D>0,O,C,10,0), COLORYELLOW;

DRAWTEXT(VAR2D>0,L,'大方神针'),COLORRED;

DRAWICON(COUNT(REF(VAR4,1)REF(VAR4,1),L*0.98,4);

DRAWICON(FILTER(COUNT(VAR6<0,5)AND CROSS(VAR6,0)AND VARF>REF(VARF,1)AND C>O,3),L,1);

DRAWICON(FILTER(REF(VAR4,1)>REF(VAR4,2)AND VAR417 AND VARB1>VARB2,5),H,2);

DRAWICON(阻力价>REF(阻力价,1)AND CROSS(阻力价,VARB3)AND C
风险提示:本指标公式仅作为知识分享,不构成任何投资建议,不作投资依据。

=====================


回复

使用道具 举报

0

主题

7

回帖

22

积分

新手上路

Rank: 1

积分
22
发表于 2023-4-24 09:08:19 | 显示全部楼层
我是来挣鲜花的,嘿嘿
回复

使用道具 举报

1

主题

10

回帖

36

积分

新手上路

Rank: 1

积分
36
发表于 2023-5-7 12:15:59 | 显示全部楼层
好贴不能沉!
回复

使用道具 举报

0

主题

10

回帖

30

积分

新手上路

Rank: 1

积分
30
发表于 2023-6-3 12:08:27 | 显示全部楼层
很好的东东
回复

使用道具 举报

0

主题

7

回帖

26

积分

新手上路

Rank: 1

积分
26
发表于 2023-6-27 16:32:01 | 显示全部楼层
支持一下:lol
回复

使用道具 举报

0

主题

4

回帖

19

积分

新手上路

Rank: 1

积分
19
发表于 2023-12-20 00:17:08 | 显示全部楼层
不容易啊!好东西!
回复

使用道具 举报

0

主题

12

回帖

36

积分

新手上路

Rank: 1

积分
36
发表于 2024-1-20 21:37:27 | 显示全部楼层
无量天尊!
回复

使用道具 举报

0

主题

12

回帖

33

积分

新手上路

Rank: 1

积分
33
发表于 2024-1-21 11:59:52 | 显示全部楼层
感谢感谢!楼主功德无量,哈哈!
回复

使用道具 举报

0

主题

12

回帖

36

积分

新手上路

Rank: 1

积分
36
发表于 2024-2-21 19:54:22 | 显示全部楼层
已收藏!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

全国统一客服电话
18976542384

24x7小时免费咨询

  • 官方在线客服

    QQ客服:股海浪子

    点击交谈

    QQ客服:beyond

    点击交谈

    QQ客服:明月

    点击交谈
  • 广东省深圳市福田区深南大道2012号

  • 添加客服微信

    可领取网站任一指标一个

  • 加入指标qq分享群

    免费领取资源

Powered by Discuz!X3.4 ©2001-2013 Comsenz Inc.彩虹桥投资充电站( 粤ICP备19084539号-1 )|网站地图