• 18976542384

    工作时间

    周一至周五:9:00-21:00

    周末及节日:9:00-18:00

  • 手机版二维码

    手机快速找资源

  • 扫描二维码

    加入官方qq群

[源码] 通达信七指共振技术指标源码

12
回复
2949
查看
[复制链接]

95

主题

12

回帖

528

积分

高级会员

Rank: 4

积分
528
发表于 2023-4-27 19:06:41 | 显示全部楼层 |阅读模式
这个就是七指共振指标源码放入附图后的效果图,最后面的源码只需要复制下来粘贴到自己的系统中去就可以了。

彩虹桥-投资充电站

原理其实很简单,就是七个指标同时发生金叉共振,会发出信号,这七个指标,我在这里是用了:量能、CCI、MACD、SAR、RSI、KDJ、CJDX,当然,懂得这个原理后,你可以编辑八指共振、十指共振等等,就是几个指标同时发出买入信号,目的是进一步确认趋势。

图上的洋红色表示指标金叉以后,绿色表示死叉以后,当七个指标同时都处在多头趋势时就会发出七指共振信号。

严格来说,七指共振应该是七个指标同时金叉才对,但是这种情况少之又少,同时处在上升通道还是比较常见,所以,我们在看盘的时候,不要认为图上的洋红色是金叉了,由绿色变洋红色才是金叉,也就是,第一次出现洋红色才是金叉出现,以后的洋红色就是指标持续向上发散。

大家可以试着用其他七个指标做出七指共振,并且,任何指标公式都可以变成选股公式,七指共振当然也不例外,我们可以通过参数的设置来选股,可以设置选股条件为几个指标由绿变红,也可以设置当天有多少个指标是洋红色,等等。

彩虹桥-投资充电站

我把技术指标公式源码分享出来

七指共振技术指标源码:【由彩虹桥投资充电站(www.xuexi199.com)整理】

STICKLINE(MA(V,5)>MA(V,10),0.6,1.4,4,0)COLORLIMAGENTA;

STICKLINE(MA(V,5)
DRAWTEXT(ISLASTBAR=1,1,'     筹码'),COLORFFFFFF;

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

STICKLINE(CCI>0,1.6,2.4,4,0)COLORLIMAGENTA;

STICKLINE(CCI<0,1.6,2.4,4,0)COLORGREEN;

DRAWTEXT(ISLASTBAR=1,2,'     CCI'),COLORFFFFFF;

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

STICKLINE(DIFF>DEA,2.6,3.4,4,0)COLORLIMAGENTA;

STICKLINE(DIFF
DRAWTEXT(ISLASTBAR=1,3,'     MACD'),COLORFFFFFF;

CC:=(C+O+H+L)/4;

STICKLINE(CC>SAR(4,2,20),3.6,4.4,4,0)COLORLIMAGENTA;

STICKLINE(CC
DRAWTEXT(ISLASTBAR=1,4,'     SAR'),COLORFFFFFF;

LC:=REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

RSI2:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;

STICKLINE(RSI1>RSI2,4.6,5.4,4,0)COLORLIMAGENTA;

STICKLINE(RSI1
DRAWTEXT(ISLASTBAR=1,5,'     RSI'),COLORFFFFFF;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

STICKLINE(K>D,5.6,6.4,4,0)COLORLIMAGENTA;

STICKLINE(K
DRAWTEXT(ISLASTBAR=1,6,'     KDJ'),COLORFFFFFF;

VAR1:=(2*CLOSE+HIGH+LOW)/4;

VAR2:=EMA(EMA(EMA(VAR1,4),4),4);

J:=(VAR2-REF(VAR2,1))/REF(VAR2,1)*100;

DD:=MA(J,3);

KK:=MA(J,1);

STICKLINE(KK>DD,6.6,7.4,4,0)COLORLIMAGENTA;

STICKLINE(KK
DRAWTEXT(ISLASTBAR=1,7,'     CJDX'),COLORFFFFFF;

T:=MA(V,5)>MA(V,10) AND CCI>0 AND DIFF>DEA AND CC>SAR(4,2,20) AND RSI1>RSI2 AND K>D AND KK>DD;

七指共振:IF(T AND REF(T,1)=0,7.4,DRAWNULL)STICK,COLORRED,LINETHICK6;

DRAWTEXT(T AND REF(T,1)=0,0.3,' 七指共振')COLORRED;

DRAWICON(T AND REF(T,1)=0,0,1);

N1:=IF(CROSS(MA(V,5),MA(V,10)),1,0);

N2:=IF(CROSS(CCI,0),1,0);

N3:=IF(CROSS(DIFF,DEA),1,0);

N4:=IF(CROSS(CC,SAR(4,2,20)),1,0);

N5:=IF(CROSS(RSI1,RSI2),1,0);

N6:=IF(CROSS(K,D),1,0);

N7:=IF(CROSS(KK,DD),1,0);

共振个数:N1+N2+N3+N4+N5+N6+N7,NODRAW;

NN1:=IF(MA(V,5)>MA(V,10),1,0);

NN2:=IF(CCI>0,1,0);

NN3:=IF(DIFF>DEA,1,0);

NN4:=IF(CC>SAR(4,2,20),1,0);

NN5:=IF(RSI1>RSI2,1,0);

NN6:=IF(K>D,1,0);

NN7:=IF(KK>DD,1,0);

同步个数:NN1+NN2+NN3+NN4+NN5+NN6+NN7,NODRAW;



回复

使用道具 举报

0

主题

10

回帖

32

积分

新手上路

Rank: 1

积分
32
发表于 2023-5-4 09:26:11 | 显示全部楼层
楼主哪儿来的这么多好东西!
回复

使用道具 举报

0

主题

11

回帖

32

积分

新手上路

Rank: 1

积分
32
发表于 2023-6-2 21:17:26 | 显示全部楼层
只为积分!感谢!
回复

使用道具 举报

0

主题

13

回帖

36

积分

新手上路

Rank: 1

积分
36
发表于 2023-6-4 00:26:06 | 显示全部楼层
感谢!
回复

使用道具 举报

0

主题

12

回帖

36

积分

新手上路

Rank: 1

积分
36
发表于 2023-6-27 00:26:14 | 显示全部楼层
牛的一批!
回复

使用道具 举报

0

主题

12

回帖

35

积分

新手上路

Rank: 1

积分
35
发表于 2023-7-17 07:46:01 | 显示全部楼层
我是个凑数的。。。
回复

使用道具 举报

0

主题

3

回帖

17

积分

新手上路

Rank: 1

积分
17
发表于 2023-7-17 19:37:35 | 显示全部楼层
my god!好东西!
回复

使用道具 举报

0

主题

10

回帖

33

积分

新手上路

Rank: 1

积分
33
发表于 2023-7-18 21:24:33 | 显示全部楼层
找到好贴不容易,我顶你了,谢了
回复

使用道具 举报

0

主题

7

回帖

24

积分

新手上路

Rank: 1

积分
24
发表于 2023-7-20 11:21:13 | 显示全部楼层
找到好贴不容易,我顶你了,谢了
回复

使用道具 举报

0

主题

6

回帖

23

积分

新手上路

Rank: 1

积分
23
发表于 2023-8-10 05:24:38 | 显示全部楼层
有道理。。。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

全国统一客服电话
18976542384

24x7小时免费咨询

  • 官方在线客服

    QQ客服:股海浪子

    点击交谈

    QQ客服:beyond

    点击交谈

    QQ客服:明月

    点击交谈
  • 广东省深圳市福田区深南大道2012号

  • 添加客服微信

    可领取网站任一指标一个

  • 加入指标qq分享群

    免费领取资源

Powered by Discuz!X3.4 ©2001-2013 Comsenz Inc.彩虹桥投资充电站( 粤ICP备19084539号-1 )|网站地图