• 18976542384

    工作时间

    周一至周五:9:00-21:00

    周末及节日:9:00-18:00

  • 手机版二维码

    手机快速找资源

  • 扫描二维码

    加入官方qq群

2024爆买出击 量少质优《通达信+指标+公式+副图+源码》

0
回复
154
查看
[复制链接]

94

主题

3

回帖

486

积分

中级会员

Rank: 3Rank: 3

积分
486
发表于 2024-4-13 13:07:56 | 显示全部楼层 |阅读模式
彩虹桥-投资充电站
副图公式源码支持 手机/电脑

G1:=CLOSE;G2:=LOW;G3:=OPEN;G4:=HIGH;
GUP0:=MA(G2,24)*1.09;
GUP1:=MA(G2,24)*1.19;
GUP2:=(COUNT(CROSS(C,GUP0),2) = 1) OR CROSS(C,GUP1);
GUP3:=REF(((COUNT((C/G3)<0.963,7))<2) AND ((C/G3)>0.94),1);
GUP4:=EMA((SLOPE(C,13)*13)+C,13);
GUP5:=HHV(GUP4,26);
GUP6:=EMA((SLOPE(C,25)*25)+C,25);
GUP7:=HHV(GUP6,55);
GUP8:=EMA((SLOPE(C,13)*20)+C,55);
GUP9:=HHV(GUP8,60);
GUP10:=EMA((SLOPE(C,21)*20)+C,55);
GUP11:=HHV(GUP10,60);
GUP12:=REF(((((((((((((C <= G3) AND (REF((COUNT(C<G3,6))<2,1))) AND ((COUNT(((((C/G3)<0.963) AND (REF(C>G3,1))) AND (G4>=REF(G4,1))) AND (G3>=REF(C,1)),7))<1)) AND ((REF(C/G3,1))<(REF(C/G3,2)))) AND ((C/MA(C,5))<1.009)) AND ((G4/C)>(REF(G4/C,1)))) AND (REF(G4,3)>REF(G4,4))) AND (REF((G3/REF(C,1))<1.04,3))) AND (VOL<REF(VOL,1))) AND ((REF(C>=G3,1)) OR (REF(C<G3,1)))) AND (G3>MA(C,5))) AND ((G4/G3)>1.001)) AND (C>G2),1);
GUP13:=(G3>MA(C,60)) AND (REF(((((C>G3) AND (REF(C,4)>REF(C,5))) AND ((REF(C/G3,1))>(REF(C/G3,2)))) AND ((REF(C/G3,2))>(REF(C/G3,3)))) AND (REF(MA(C,5)>MA(C,20),2)),1));
GUP14:=(((C>GUP5) AND (C>GUP7)) AND (C>GUP9)) AND (C>GUP11);
GUP15:=(COUNT(CROSS(C,GUP5),4)>=1) OR CROSS(C,GUP7);
GUP16:=CROSS(C,GUP9) AND CROSS(C,GUP11);
GUP17:=((C-MA(C,60))/MA(C,60))*100;
GUP18:=(COUNT(GUP17<35,100))>=2;
GUP19:=((MACD.MACD>REF(MACD.MACD,1)) AND (MACD.MACD>-0.085)) AND (REF(MACD.MACD<1.35,3));
GUP20:=((C/(REF(HHV(G4,13)>0.97,1))) AND ((G4/C)<1.03)) AND ((((ATAN(((MA(C,60)/REF(MA(C,60),1))-1)*100))*180)/3.1416)>=0);
GUP21:=((G3/MA(C,5))<0.9998) AND (((REF(C>G3,2)) AND (REF(G4,2)>REF(G4,3))) OR ((REF(C <= G3,2)) AND (C>REF(G4,2))));
GUP22:=(((MA(C,5)>MA(C,10)) OR ((G3/MA(C,10))>0.999)) OR ((G3/MA(C,20))>0.99)) OR ((G3/MA(C,30))>0.99);
GUP23:=((C/REF(C,1))>=1.04) OR ((C/G3)>1.04);
爆买:=((((((((((GUP19 AND GUP20) AND GUP22) AND GUP21) AND GUP23) AND (GUP13 OR GUP12)) AND ((GUP14 OR GUP15) OR GUP16)) AND GUP2) AND GUP3) AND GUP18) AND (G3<REF(G4,1))) AND (((REF(VOL,1)<REF(VOL,2)) OR (REF(VOL,1)<REF(VOL,3))) OR (REF(VOL,3)<REF(VOL,4)));
STICKLINE(爆买,60,90,1,0),COLORMAGENTA;
STICKLINE(爆买,30,60,2,0),COLORRED;
STICKLINE(爆买,10,30,3,0),COLORYELLOW;

选股公式源码



{选股公式:爆买}
G1:=CLOSE;G2:=LOW;G3:=OPEN;G4:=HIGH;
GUP0:=MA(G2,24)*1.09;
GUP1:=MA(G2,24)*1.19;
GUP2:=(COUNT(CROSS(C,GUP0),2) = 1) OR CROSS(C,GUP1);
GUP3:=REF(((COUNT((C/G3)<0.963,7))<2) AND ((C/G3)>0.94),1);
GUP4:=EMA((SLOPE(C,13)*13)+C,13);
GUP5:=HHV(GUP4,26);
GUP6:=EMA((SLOPE(C,25)*25)+C,25);
GUP7:=HHV(GUP6,55);
GUP8:=EMA((SLOPE(C,13)*20)+C,55);
GUP9:=HHV(GUP8,60);
GUP10:=EMA((SLOPE(C,21)*20)+C,55);
GUP11:=HHV(GUP10,60);
GUP12:=REF(((((((((((((C <= G3) AND (REF((COUNT(C<G3,6))<2,1))) AND ((COUNT(((((C/G3)<0.963) AND (REF(C>G3,1))) AND (G4>=REF(G4,1))) AND (G3>=REF(C,1)),7))<1)) AND ((REF(C/G3,1))<(REF(C/G3,2)))) AND ((C/MA(C,5))<1.009)) AND ((G4/C)>(REF(G4/C,1)))) AND (REF(G4,3)>REF(G4,4))) AND (REF((G3/REF(C,1))<1.04,3))) AND (VOL<REF(VOL,1))) AND ((REF(C>=G3,1)) OR (REF(C<G3,1)))) AND (G3>MA(C,5))) AND ((G4/G3)>1.001)) AND (C>G2),1);
GUP13:=(G3>MA(C,60)) AND (REF(((((C>G3) AND (REF(C,4)>REF(C,5))) AND ((REF(C/G3,1))>(REF(C/G3,2)))) AND ((REF(C/G3,2))>(REF(C/G3,3)))) AND (REF(MA(C,5)>MA(C,20),2)),1));
GUP14:=(((C>GUP5) AND (C>GUP7)) AND (C>GUP9)) AND (C>GUP11);
GUP15:=(COUNT(CROSS(C,GUP5),4)>=1) OR CROSS(C,GUP7);
GUP16:=CROSS(C,GUP9) AND CROSS(C,GUP11);
GUP17:=((C-MA(C,60))/MA(C,60))*100;
GUP18:=(COUNT(GUP17<35,100))>=2;
GUP19:=((MACD.MACD>REF(MACD.MACD,1)) AND (MACD.MACD>-0.085)) AND (REF(MACD.MACD<1.35,3));
GUP20:=((C/(REF(HHV(G4,13)>0.97,1))) AND ((G4/C)<1.03)) AND ((((ATAN(((MA(C,60)/REF(MA(C,60),1))-1)*100))*180)/3.1416)>=0);
GUP21:=((G3/MA(C,5))<0.9998) AND (((REF(C>G3,2)) AND (REF(G4,2)>REF(G4,3))) OR ((REF(C <= G3,2)) AND (C>REF(G4,2))));
GUP22:=(((MA(C,5)>MA(C,10)) OR ((G3/MA(C,10))>0.999)) OR ((G3/MA(C,20))>0.99)) OR ((G3/MA(C,30))>0.99);
GUP23:=((C/REF(C,1))>=1.04) OR ((C/G3)>1.04);
爆买 彩虹桥-投资充电站 (((((((((GUP19 AND GUP20) AND GUP22) AND GUP21) AND GUP23) AND (GUP13 OR GUP12)) AND ((GUP14 OR GUP15) OR GUP16)) AND GUP2) AND GUP3) AND GUP18) AND (G3<REF(G4,1))) AND (((REF(VOL,1)<REF(VOL,2)) OR (REF(VOL,1)<REF(VOL,3))) OR (REF(VOL,3)<REF(VOL,4)));
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

全国统一客服电话
18976542384

24x7小时免费咨询

  • 官方在线客服

    QQ客服:股海浪子

    点击交谈

    QQ客服:beyond

    点击交谈

    QQ客服:明月

    点击交谈
  • 广东省深圳市福田区深南大道2012号

  • 添加客服微信

    可领取网站任一指标一个

  • 加入指标qq分享群

    免费领取资源

Powered by Discuz!X3.4 ©2001-2013 Comsenz Inc.彩虹桥投资充电站( 粤ICP备19084539号 )|网站地图